Aruba CX 6300 Switch Stacking

Stacking Aruba CX 6300 switches allows you to manage a group of switches as a single entity, increasing network availability and simplifying management. Aruba calls stacking VSF or Virtual Switching Framework.

Prerequisites:

  • Two or more Aruba CX 6300 switches
  • Appropriate stacking cables
  • Refer to https://www.arubanetworks.com/techdocs/AOS-CX/10.05/HTML/5200-7324/index.html#book.html for more information.

Steps:

First, you’ll want to ensure you have a means to console into the switch using a USB-C cable or use the management port with the default DHCP client. The console port is only USB-C so you’ll need that cable and the chipset appears to be build into the switch itself and should be identified by your operating system and then within SecureCRT or whatever terminal emulator you use.

Next, you will want to ensure all switches in the stack are running the same version of code to begin with. You can upgrade the switches once they are stacked to speed up the upgrade process.

Wire the stacking cables between switches starting with port 50 on top/master switch to port 49 on next switch and so on repeating that pattern for all switches in the stack.

From the Master switch run:

conf t

vsf start-auto-stacking

The stack should form and the member switches will reboot.

Wait for switches to fully come back up.

Verify the stack using this command: show vsf

Check the orange plastic labels that slide out of the front panel of the switch to ensure the switch members are in proper order by verifying the MAC address of each switch in the stack.

Next, the switches can be upgraded from the WebGUI by using the management IP of the stack


Cisco vPC Setup and Caveats

This was my first time setting up Cisco vPC between two Nexus 3K switches and I wanted to document some findings the deviated from their documentation a bit.

NXOS: version 7.0(3)I7(6) was used in this environment.

Here is the topology:

https://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus3000/sw/layer2/503_U2_1/b_Cisco_n3k_layer2_config_guide_503_U2_1/b_Cisco_n3k_layer2_config_gd_503_U2_1_chapter_01000.html#concept_692519898AC94234AAE63D401054816A

The above link does a great job explaining the requirements for vPC and what is involved including using LACP. The only real caveat is when creating the Etherchannel for the vPC peer or downstream port-channels I had to follow this order specifically or it would say that the ports were not compatible when I tried to add them to a port-channel using the channel group command. Cisco’s documentation for Etherchannel suggests adding the port-channel interface first then adding the individual ports to the port-channel.

First add the ports to the port-channel then create the port-channel interface:

conf t
int e 1/49
switchport mode trunk
channel-group 100 mode active

int e 1/50
switchport mode trunk
channel-group 100 mode active

exit

int port-channel 100
switchport mode trunk

Here is a full snippet relevant to the vPC config:

Nexus A:

vrf context management
ip route 0.0.0.0/0 10.10.10.1

vpc domain 1
peer-keepalive destination 10.10.10.20 source 10.10.10.10
auto-recovery

interface port-channel1
switchport mode trunk
vpc 1

interface port-channel100
switchport mode trunk
spanning-tree port type network
vpc peer-link

interface Ethernet1/48
switchport mode trunk
channel-group 1 mode active

interface Ethernet1/49
switchport mode trunk
channel-group 100 mode active

interface Ethernet1/50
switchport mode trunk
channel-group 100 mode active

interface mgmt0
vrf member management
ip address 10.10.10.10/24
line console
Nexus B:

vrf context management
ip route 0.0.0.0/0 10.10.10.1

vpc domain 1
peer-keepalive destination 10.10.10.10 source 10.10.10.20
auto-recovery

interface port-channel1
switchport mode trunk
vpc 1

interface port-channel100
switchport mode trunk
spanning-tree port type network
vpc peer-link

interface Ethernet1/48
switchport mode trunk
channel-group 1 mode active

interface Ethernet1/49
switchport mode trunk
channel-group 100 mode active

interface Ethernet1/50
switchport mode trunk
channel-group 100 mode active

interface mgmt0
vrf member management
ip address 10.10.10.20/24
line console
Nexus C:

vrf context management
ip route 0.0.0.0/0 10.10.10.1

interface port-channel1
switchport mode trunk

interface Ethernet1/49
switchport mode trunk
channel-group 1 mode active

interface Ethernet1/50
switchport mode trunk
channel-group 1 mode active

interface mgmt0
vrf member management
ip address 10.10.10.30/24
line console